Cynosure.X International

:

Add Comment | Related Links | TrackBack
Related Content

MagicMenu Works Great For Years, But Suddenly Stopped Functioning

Magicmenu worked great for years to hide the finder menu but suddenly stopped functioning. However, it does work if I boot under safe mode. I tried to eliminate all startup items to no avail. Any suggestions regarding what the problem or conflict might be? It worked under 10.6.8 up until about Feb. 2012.

vic
Fri, 09 Mar 2012 19:46:16 +0300

Did you get an Mac OS X update recently? Say in February?

Does it effect all applications? Or just one application?

Pick an application, such as Firefox. Apply MagicMenu to it again. Does it work now? Or is it still not working?

Mel
Fri, 09 Mar 2012 20:08:37 +0300

I have always just used it to eliminate the menu in the finder not with any applications. When used in conjunction with both camouflage and cursorcerer, MagicMenu had provided a full screen, clean desktop picture on my laptop. Now it no longer works even when those other programs are not loaded at startup. A security update was issued on Feb. 1 so that might be the cause. But, as I mentioned MagicMenu works fine in safe mode with that update installed.

vic
Fri, 09 Mar 2012 22:16:51 +0300

Have you tried to turn MagicMenu off on the Finder and then MagicMenu on again to see if it works?

Mel
Fri, 09 Mar 2012 22:21:42 +0300

I have tried a lot of things. MagicMenu will only turn off/on in safe mode. I tried reinstalling the system, restoring from backup, manually fiddling with the info.plist etc. Something strange is going on but I am out of ideas. If no one else is having problems it might be specific to my setup.

vic
Fri, 09 Mar 2012 22:46:57 +0300

If you are already down at the level of changing info.plist, then I suspect Apple has closed the door on you. There isn't anything special that MagicMenu is doing to the info.plist that you probably aren't already doing.

You can try rolling back the update and see if it solves the problem.

Mel
Fri, 09 Mar 2012 23:56:06 +0300

Working again!!! I saw a tip by Dimmer that the security update problems can be rectified by deinstalling Xcode http://www.macintouch.com/readerreports/snowleopard/index.ht . . . I ran an Xcode uninstall using the terminal according to http://macdevelopertips.com/xcode/how-to-uninstall-xcode.htm . . . and MagicMenu started working after a restart. Curiously however, Xcode is still present on my Mac.

vic
Fri, 16 Mar 2012 19:09:44 +0300

That's great to hear! Thanks for sharing your solution with us.

Mel
Fri, 16 Mar 2012 21:47:23 +0300

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 2 - 2?
Click button only once, please!

TrackBack

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.

Products | Services
Forums | Latest | RSS
Library | Search | Wiki
Help | Licenses

Login | Register

29 Users Online

Hacking Digital Cameras
Fun for Photographers


Amazon Associate

Copyright © 1996 - 2017. All Rights Reserved.